WordPress 5.0 – Dudas sobre Gutenberg

logo wordpress

La principal novedad de WordPress 5.0 es el editor de bloques Gutenberg.

Gutenberg sustituye al editor clásico de wordpress (TinyMCE) modificando sensiblemente la manera de trabajar. Se trata de un editor basado en bloques de contenido, que inicia el camino hacia un nuevo modelo de WordPress que afectará a otros componentes como, por ejemplo, menús o widgets. Los bloques están desarrollado con JavaScript y son independientes de la aplicación, por lo que pronto veremos este mismo sistema en otros gestores de contenidos distintos a wordpress.

editor de wordpress Gutenberg
Uno de los problemas iniciales de Gutenberg es su incompatibilidad con muchos de nuestros plugins, lo que previsiblemente va a retrasar la actualización de multitud de sitios web. Para facilitar el cambio, los propios desarrolladores incentivan la instalación del editor clásico (como plugin) durante el proceso de instalación de la nueva versión.

WordPress 5.0 aporta también importantes mejoras de seguridad, afina sus capacidades de adaptación a las pantallas de los dispositivos móviles, etc. Pero la cuestión ahora, en respuesta a varias de las consultas que hemos recibido en los últimos días, es: ¿ Conviene actualizar WordPress a la versión 5.0 ?

Hay dudas sobre la continuidad de Gutenberg, en WordPress.com se están planteando sustituirlo por Elementor (un editor más completo), ya para la version 5.1. Por lo tanto no hay que tener prisa, habría que resolver antes la compatibilidad de las principales extensiones que tengamos instaladas y, especialmente si tenemos una tienda con WooCommerce, es muy importante actualizar primero a WooCommerce 3.51. En definitiva, si no eres un experto o un usuario avanzado en WordPress, recomendamos que no actualices aún, o bien que te asesores antes de hacerlo.

No hay comentarios

Dejar un comentario